summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-06-25 08:48:21 -0400
committeracxz2020-06-25 08:48:21 -0400
commit5700609d87c6742ac37975e4b83c0cea3f7b83df (patch)
tree787068c50992f45caa30f0c89006ffd8632e03f9 /PKGBUILD
downloadaur-python-rtyaml.tar.gz
[python-rtyaml] create python-rtyaml package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc61b4fc3c49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=python-rtyaml
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='All the annoying things to make YAML usable in a source controlled environment.'
+arch=('any')
+url='https://github.com/unitedstates/rtyaml'
+license=('CC0')
+depends=('python' 'python-pyaml' 'libyaml')
+makedepends=('python' 'python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/be/2f/e2b907ac01ecc56efac82b6fc9fa411403fe430f5e2e2e7ce86858bc1aab/rtyaml-${pkgver}.tar.gz")
+sha256sums=('66aa6e2f2c8c29ccab9d1713072a4e06c52c6cdcfe27ebd50706df09638c4586')
+
+_pkgname=rtyaml
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}