summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzachary.perzan@gmail.com2020-09-01 19:47:44 -0700
committerzachary.perzan@gmail.com2020-09-01 19:47:44 -0700
commit28d4cf6b5af83d7b38949aa61c2e52c43eb456a6 (patch)
tree83d4ca4d27eccb3d43066a192e6b3b3108c68d51 /PKGBUILD
parent9e0479d7a13eed0fc4e70a03a7a0394e1ee61d74 (diff)
downloadaur-python-salib.tar.gz
Update to v1.3.11, remove python2 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 17 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60e08534cad1..6eccc2c093a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,27 @@
+# Maintainer: cozisco <cozisco at gmail dot com>
pkgbase=python-salib
-pkgname=('python-salib' 'python2-salib')
-pkgver=1.1.3
+pkgname=('python-salib')
+_pyname=SALib
+pkgver=1.3.11
pkgrel=1
-pkgdesc="Sensitivity Analysis Library in Python (Numpy). Contains Sobol, Morris, and FAST methods."
-url="https://github.com/jdherman/SALib"
+pkgdesc="Tools for sensitivity analysis. Contains Sobol, Morris, and FAST methods"
+url="http://salib.github.io/SALib/"
arch=(any)
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-numpy' 'python2-numpy' 'python-pyscaffold' 'python2-pyscaffold' 'git')
-source=("https://github.com/jdherman/SALib/archive/v$pkgver.tar.gz")
-sha256sums=('e6256c2dfcffb98bb975fcd6fd2330e1a5d2727da648b23f0938ad35d552206b')
+depende=('python-numpy' 'python-matplotlib' 'python-scipy' 'python-pandas')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz")
+sha256sums=('af07e284ce1e85d2fea6c571b4b3d5c518f70faa518ed890ca4212bd0ad0d3d8')
build() {
- cp -r "${srcdir}"/SALib-$pkgver "${srcdir}"/SALib-$pkgver-py2
-
- cd "${srcdir}"/SALib-$pkgver
- git init
- python setup.py build
-
- cd "${srcdir}"/SALib-$pkgver-py2
- git init
- python2 setup.py build
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python setup.py build
}
package_python-salib() {
- depends=('python-numpy')
-
- cd "${srcdir}/SALib-$pkgver"
- python setup.py install --root=${pkgdir} --optimize=1
+ depends=('python-numpy' 'python-matplotlib' 'python-scipy' 'python-pandas')
+
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-salib/LICENSE.txt"
}
-
-package_python2-salib() {
- depends=('python2-numpy')
-
- cd "${srcdir}/SALib-$pkgver"
- python2 setup.py install --root=${pkgdir} --optimize=1
-}
-