summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2022-02-20 01:51:48 -0300
committerDanilo J. S. Bellini2022-02-20 01:51:48 -0300
commit63438e3ae6e7fec0d07a49361b70efe251f61338 (patch)
tree81e30a4b2e434f7a847c7168c9836680c52b3654 /PKGBUILD
parent54c3b90a3a17495dae670d73f9113bd137369665 (diff)
downloadaur-python-scielo-xylose.tar.gz
v1.35.9-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52a663db282d..79c0dd3b67a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
_name=xylose
pkgname=('python-scielo-xylose')
-pkgver=1.34.1
+pkgver=1.35.9
pkgrel=1
pkgdesc="SciELO's library to abstract a JSON from ISIS2JSON type 3 results"
arch=('any')
@@ -10,16 +10,11 @@ license=('BSD')
makedepends=('python-setuptools')
depends=('python-scielo-legendarium')
options=(!emptydirs)
-sha256sums=('5f0b343003e90a600f4b58d9971caeee98d9cb69cce677d8c1681cd0e78753c9'
- '611f9cee8598e86564f391797789c08e11877534727a9b235dce210bde17cf6b')
-_pypi='https://files.pythonhosted.org/packages'
-_path='eb/98/af79056f6fd0c470bebf08c584a77c46c71ab13dc3eeeef15016d8d5d825'
-_chash=2050c1019c1a70b945faeea3fd9b948309db9a0f
-source=("$_pypi/$_path/$_name-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/scieloorg/xylose/$_chash/LICENSE")
+sha256sums=('b8581f317ef8b11d5f964a7cc1f1d245f717433e9910211aeafef3b3f707af15')
+source=("$_name-v$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
package() {
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}