summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMateen Ulhaq2023-02-04 18:22:03 -0800
committerMateen Ulhaq2023-02-04 18:22:03 -0800
commitc4d0c362ddce38b7e6c4548f393e5296702f0786 (patch)
tree920eeb530114a4db244b0815766b689707ba50eb /PKGBUILD
downloadaur-python-segment-analytics.tar.gz
init: python-segment-analytics 2.2.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0837b6f16020
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+# Maintainer: Mateen Ulhaq <mulhaq2005+aur at gmail dot com>
+
+pkgbase='python-segment-analytics'
+pkgname=('python-segment-analytics')
+_module='segment-analytics-python'
+pkgver='2.2.2'
+pkgrel=1
+pkgdesc="The hassle-free way to integrate analytics into any python application."
+url="https://github.com/segmentio/analytics-python"
+depends=(
+ 'python'
+ "python-backoff"
+ "python-dateutil"
+ "python-monotonic"
+ "python-requests"
+)
+makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-pylint' 'flake8')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('10ef6ee42b9e504b9db76b44c893e6a44c3ebc51cd01f475ac76f0e80a8fff09')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}" || exit 1
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}" || exit 1
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+check() {
+ cd "${srcdir}/${_module}-${pkgver}" || exit 1
+ make test
+}