summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÓscar García Amor2018-07-12 12:13:49 +0200
committerÓscar García Amor2018-07-12 12:13:49 +0200
commit4204e7dfe8a711b74510efeff47c1c99f9607b4b (patch)
treecacf63e911ea5369f607433944c8beb1125b27e1 /PKGBUILD
downloadaur-python-send-cli.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..519bfcfe8b16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Oscar Garcia Amor <ogarcia@connectical.com>
+
+_commit='7f9458299f42e3c558f00e77cf9d3aa9dd857457'
+pkgname=python-send-cli
+pkgver=2018.04.08
+pkgrel=1
+pkgdesc='Unofficial command line for Firefox Send'
+arch=('any')
+url='https://github.com/ehuggett/send-cli'
+license=('GPL3')
+depends=('python-beautifulsoup4' 'python-pycryptodomex'
+ 'python-requests-toolbelt' 'python-tqdm')
+makedepends=('python-setuptools')
+source=("https://github.com/ehuggett/send-cli/archive/${_commit}.tar.gz")
+sha256sums=('d6dd7102adba2e8ce5301c636768eb699859b7b70b7187ec0aa48e2868ad38ec')
+
+package() {
+ cd send-cli-${_commit}
+
+ python setup.py install --root="${pkgdir}" --optimize='1'
+}