summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-10-02 15:32:57 -0500
committerLuis Martinez2021-10-02 15:35:42 -0500
commit171e84c4c95d7c8257b72ee826f6edc1ae0020ca (patch)
treee620008e18877253878b09afed58746b3e7d5380 /PKGBUILD
parent03c2352ea3d0c18a96ce161bc39b9f0aa59d6c7c (diff)
downloadaur-python-sercol.tar.gz
update to 0.1.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 41 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df7e4238ba33..7499750ca07f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,59 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
-_name=sercol
-pkgbase='python-sercol'
+pkgbase=python-sercol
pkgname=('python-sercol' 'python2-sercol')
-pkgver=0.1.0
-pkgrel=2
-pkgdesc="Rich collection class with grouping and filtering helpers in Python"
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Rich collection class with grouping and filtering helpers"
arch=('any')
url="https://pypi.python.org/pypi/sercol"
license=('Apache')
-makedepends=(
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools')
-options=(!emptydirs)
-source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/ca/6a/2e99f1b7e37f3506bfa50894ad934249d1e2c6a97e6d01d49a2fc02fd805/sercol-0.1.0.tar.gz)
-sha256sums=('8579bc0031d78a4e0b8d77abcbd22c76fe4b56160f1d344717eca67b22ff9412')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=(
+ 'python-nose'
+ 'python-serializable'
+ 'python-simplejson'
+ 'python-pandas'
+
+ 'python2-nose'
+ 'python2-serializable'
+ 'python2-simplejson'
+ 'python2-pandas'
+ 'python2-pytz')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/s/sercol/sercol-$pkgver.tar.gz")
+sha256sums=('eab962cf60bccb3c500b0eac7f51e865efefc4203d0323da3c4d5414e0b4e577')
prepare() {
- cp -a "${_name}"-"${pkgver}"{,-py2}
+ cp -a "sercol-$pkgver"{,-py2}
}
build(){
- cd "${srcdir}"/"${_name}"-"${pkgver}"
- python setup.py build
+ cd "$srcdir/sercol-$pkgver"
+ python setup.py build
- cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
- python2 setup.py build
+ cd "$srcdir/sercol-$pkgver-py2"
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir/sercol-$pkgver"
+ python setup.py nosetests
+
+ cd "$srcdir/sercol-$pkgver-py2"
+ python2 setup.py nosetests
}
package_python2-sercol() {
- depends=(
- 'python2'
- 'python2-serializable'
- 'python2-simplejson'
- 'python2-pandas'
- )
-
- cd "${_name}"-"${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ depends=('python2-serializable' 'python2-simplejson' 'python2-pandas')
+
+ cd "sercol-$pkgver-py2"
+ PYTHONHASHSEED=0 python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
package_python-sercol() {
- depends=(
- 'python'
- 'python-serializable'
- 'python-simplejson'
- 'python-pandas'
- )
-
- cd "${_name}"-"${pkgver}"
- python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ depends=('python-serializable' 'python-simplejson' 'python-pandas')
+
+ cd "sercol-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}