summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2024-02-09 12:43:38 +0100
committerAlphaJack2024-02-09 12:43:38 +0100
commitb4e155bdcc7cd25d86458cf0cfb500d8f36fe921 (patch)
tree03da8f31e5ba79d184440176a2ed71dd26b813d2 /PKGBUILD
downloadaur-python-shortid.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a64bb63f57c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="python-shortid"
+_name="shortid"
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Short id generator"
+arch=(any)
+url="https://github.com/corpix/shortid"
+license=("MIT")
+makedepends=("python-build" "python-installer" "python-setuptools" "python-wheel")
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+b2sums=('2b00299bda5c96f40e06707814f42a56c1daebe2e7fa2d889af045b1a2b7d6883c679bcd08329d2778f106f8b014c1b6f321b7fa0cd6549abea5f0a80f98998a')
+options=("!strip")
+
+prepare(){
+ cd "$_name-$pkgver"
+ sed -i "setup.cfg" \
+ -e "s|description-file|description_file|"
+}
+
+build(){
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}