summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoelof Rietbroek2024-05-24 23:25:00 +0200
committerRoelof Rietbroek2024-05-24 23:25:00 +0200
commit612eff0345d0637e512ae125282f60b2e843c019 (patch)
tree8bb119ed5fa064c84698aa0ad714b1f55ad463c2 /PKGBUILD
parentfec2b051b1797f6937f78912d67bd7822f55e643 (diff)
downloadaur-python-shtools.tar.gz
change build system and update to 4.12.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb2fee921015..4f898729428f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
# Maintainer: Roelof Rietbroek <roelof@wobbly.earth>
pkgbase=python-shtools
pkgname=(shtools python-shtools)
-pkgver=4.10.3
+pkgver=4.12.2
pkgrel=0
pkgdesc="SHTOOLS: Tools for working with spherical harmonics"
arch=('any')
-url="https://shtools.oca.eu"
+url="https://shtools.github.io/SHTOOLS/"
license=('BSD 3-clause')
depends=("fftw" "blas" "lapack")
-makedepends=("gcc-fortran" "python-setuptools")
-source=("https://github.com/SHTOOLS/SHTOOLS/archive/v$pkgver.tar.gz" "site.cfg" )
-noextract=()
-sha256sums=('ff630d6eeea73891c8c50bc73ad1c8539b7a0b5095449fbad1554493c4714d1e'
- '19a427bf02f65ffc062ad817c3fa1d56ded3b53a362c4d1258e3ed98c840cdb2')
+makedepends=("gcc-fortran" "meson")
+source=("https://github.com/SHTOOLS/SHTOOLS/archive/v$pkgver.tar.gz" )
+sha256sums=('dcbc9f3258e958e3c8a867ecfef3913ce62068e0fa6eca7eaf1ee9b49f91c704')
+
+
prepare(){
cd ${srcdir}/SHTOOLS-${pkgver}/
- cp ../site.cfg .
+ #i We need to explicitly add the version to pyproject.toml because we're not working from the git tree
+ sed -i -e "/\[project\]/a version = \"${pkgver}\"" -e "/^dynamic/,+3d" pyproject.toml
cd ${_startdir}
}
@@ -27,7 +28,7 @@ package_python-shtools() {
pkgdesc="Python interface for SHTOOLS (pyshtools)"
depends+=( "python-numpy" "python-astropy" "python-pooch" "python-xarray" )
cd ${srcdir}/SHTOOLS-${pkgver}/
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ pip install --root "${pkgdir}" --no-deps --prefix=usr .
cd ${_startdir}
}