summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-10-02 21:36:24 -0500
committerLuis Martinez2021-10-02 21:43:29 -0500
commitaf25a1daf8d6fc572f4c8fae9111fbede997b7c2 (patch)
tree17e9b6ee9783545c19f3c10ffb2b76a1e15eaefb /PKGBUILD
parent25f827ed88d06153f117b25e55a6d87b10da361c (diff)
downloadaur-python-shyaml.tar.gz
update to 0.6.2
package rewritten to comply with Python packaging guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da19b033060f..430ccee4943e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
-# Maintainer: Sean Enck <enckse@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Sean Enck <enckse@gmail.com>
# Contributor: Sanpi <sanpi+aur@homecomputing.fr>
+
pkgname=python-shyaml
-pkgver=0.5.0
+pkgver=0.6.2
pkgrel=1
pkgdesc='YAML for the command line'
-arch=('x86_64')
+arch=('any')
url='https://github.com/0k/shyaml'
license=('BSD')
-depends=('python' 'python-yaml')
-makedepends=()
-source=("git+https://github.com/0k/shyaml.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd "$srcdir/shyaml"
+depends=('python-yaml')
+makedepends=('git' 'python-d2to1' 'python-setuptools')
+changelog=CHANGELOG.rst
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/s/shyaml/shyaml-$pkgver.tar.gz")
+sha256sums=('696e94f1c49d496efa58e09b49c099f5ebba7e24b5abe334f15e9759740b7fd0')
- git checkout $pkgver
+build() {
+ cd "shyaml-$pkgver"
+ python setup.py build
}
package() {
- cd "$srcdir/shyaml"
-
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "shyaml-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
}