summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2022-09-16 16:55:51 +0200
committerPhilipp A2022-09-16 16:55:51 +0200
commitaef538df5be26b0780a15e8f28f8563c87062317 (patch)
tree96b475cacfe59903879bdc541b13b672aa9e5817 /PKGBUILD
parent7f79fdca6da9169e53e59bcaf9bec82e335a5655 (diff)
downloadaur-python-soundcard-git.tar.gz
makedeps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2845bf82be76..88caceb9d1f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=python-soundcard-git
-pkgver=0.3.3.r10.gc03a9f9
+pkgver=0.4.2.r7.g213aa0a
pkgrel=1
pkgdesc='Play and record audio without resorting to CPython extensions'
arch=(any)
@@ -11,8 +11,8 @@ license=('BSD3')
depends=(python python-numpy python-cffi)
provides=("python-soundcard=$pkgver")
conflicts=(python-soundcard)
-makedepends=('python-setuptools')
-source=("git+https://github.com/bastibe/SoundCard.git")
+makedepends=(python-setuptools python-build python-installer python-wheel)
+source=("git+$url.git")
sha512sums=('SKIP')
pkgver() {
@@ -22,7 +22,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "$srcdir/SoundCard"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "$srcdir/SoundCard"
- python setup.py install --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+