summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 20:30:28 +0200
committerAntonio Rojas2022-04-01 20:30:28 +0200
commitd3e1de0c273f493a4656b217f6e0e13cb016bca8 (patch)
treef2fe7e1c26efac0fd11b7820f05e7a8aab42e3cb /PKGBUILD
downloadaur-python-sourceinspect.tar.gz
import from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..063d8b9483bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=python-sourceinspect
+pkgver=0.0.3
+pkgrel=2
+pkgdesc='Unified inspector for retrieving sources from Python objects'
+arch=(any)
+url='https://github.com/taichi-dev/sourceinspect'
+license=(unknown)
+makedepends=(git python-setuptools)
+source=("git+$url#commit=2532324e7a1d33d6ead12ab03de7834d4a74eac9") # tag: v0.0.3
+b2sums=('SKIP')
+
+build() {
+ cd sourceinspect
+ python setup.py build
+}
+
+package() {
+ cd sourceinspect
+ python setup.py install --root="$pkgdir" --optimize=1
+}