summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Epaneshnikov2021-07-15 11:33:33 +0300
committerAlexander Epaneshnikov2021-07-15 11:33:33 +0300
commit6e9dcabfae621b7354ecbbec858b37c7dfecd092 (patch)
tree879522b8f404ef032d637dae0cf854f5ecb9f785 /PKGBUILD
parent7ce06b41a3d8e3ae24e1c178ef8932b6d1f82c0d (diff)
downloadaur-python-spake2.tar.gz
upgpkg: python-spake2 0.8-7
run tests, fix url
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2df107e15f70..4292d5b60d80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# maintainer Storm Dragon <stormdragon2976@gmail.com>
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Maintainer: Alexander Epaneshnikov <aarnaarn2@gmail.com>
-pkgname='python-spake2'
+pkgname=python-spake2
pkgver=0.8
-pkgrel=6
-pkgdesc="This library implements the SPAKE2 password-authenticated key exchange"
+pkgrel=7
+pkgdesc="Pure-python implementation of the SPAKE2 Password-Authenticated Key"
arch=('any')
-url="https://pypi.python.org/packages/10/7d/spake2-${pkgver}"
+url="https://github.com/warner/python-spake2"
license=('MIT')
-depends=('python' 'python-hkdf')
+depends=('python' 'python-hkdf')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/s/spake2/spake2-${pkgver}.tar.gz")
-md5sums=('0155bad518bb49c39994fe0b7d9fb32c')
+checkdepends=('python-pytest')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/warner/python-spake2/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('908c377c831f4a11551973ca917b113d51a66c533d35fd19b2692fdb7e575ed2a5045d9b632bc55c37b68ad092f01dff5da191e9dfbfb5599b72844788438d68')
build() {
- cd "$srcdir"/spake2-${pkgver}
+ cd "${pkgname}-${pkgver}"
python setup.py build
}
-
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ pytest
+}
+
package() {
- cd "$srcdir/spake2-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -vDm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
# vim:set ts=2 sw=2 et: