summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCyrilWaechter2022-12-13 22:56:04 +0100
committerCyrilWaechter2022-12-13 22:56:04 +0100
commit85fad6ae4ff6836b69db586e6f64d73751cabb7f (patch)
tree45833ad8ef5566186b83e10fbd6018d6268051b4 /PKGBUILD
parent53a9fac627bfd14fda1a3ded0bc39edaeab84cdb (diff)
downloadaur-python-specklepy-git.tar.gz
Update path and for python 3.10+
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4285e024777e..2929f2b83001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
pkgname=(python-specklepy-git)
-pkgver=2.1.0.r8.g46437e7
+pkgver=2.9.1.r10.g67499ab
pkgrel=1
pkgdesc="This is the start of the Python client for Speckle 2.0. It is currently quite nebulous and may be trashed and rebuilt at any moment! It is compatible with Python 3.6+."
arch=('x86_64' 'i686')
@@ -14,10 +14,10 @@ conflicts=()
replaces=()
backup=()
source=("git+https://github.com/specklesystems/speckle-py.git")
-_python_ver=$(python --version | grep -Po 'Python \K[0-9]\..')
+_python_ver=$(python --version | grep -Po 'Python \K[0-9].[0-9]+')
prepare() {
- cd "${srcdir}/speckle-py"
+ cd "${srcdir}/speckle-py/src"
}
pkgver() {
@@ -31,7 +31,7 @@ pkgver() {
}
build() {
- cd "${srcdir}/speckle-py"
+ cd "${srcdir}/speckle-py/src"
}
package() {
@@ -42,7 +42,7 @@ package() {
# Install python modules
mkdir -p "${pkgdir}/usr/lib/python${_python_ver}/site-packages/"
cd "${pkgdir}/usr/lib/python${_python_ver}/site-packages/"
- cp -rf "${srcdir}/speckle-py/specklepy" "./"
+ cp -rf "${srcdir}/speckle-py/src/specklepy" "./"
python -O -m compileall "./"
}