summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-04-28 11:35:56 +0200
committerKlaus Alexander Seistrup2024-04-28 11:35:56 +0200
commit1a60bbb7cec1812d37f85705e5dffd59417db4ee (patch)
tree601aa22ba4203b168f872c9e50cab9c9c5384f49 /PKGBUILD
parentf2488abe3ba02cc9a74200371ee8c9abd93c6118 (diff)
downloadaur-python-sphinx-markdown-tables.tar.gz
Bump for Python 3.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 493a82aa0c89..2bb418cefe2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname='python-sphinx-markdown-tables'
_pkgname="${pkgname##python-}"
pkgver=0.0.17
-pkgrel=5
+pkgrel=6
arch=('any')
license=('GPL-3.0-or-later') # SPDX-License-Identifier: GPL-3.0-or-later
pkgdesc='Sphinx extension for rendering tables written in markdown'
@@ -23,19 +23,19 @@ makedepends=(
)
prepare() {
- cd "$srcdir/$_pkgname-$pkgver" || exit 1
+ cd "$srcdir/$_pkgname-$pkgver"
sed -i '/data_files/d' setup.py
}
build() {
- cd "$srcdir/$_pkgname-$pkgver" || exit 1
+ cd "$srcdir/$_pkgname-$pkgver"
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/$_pkgname-$pkgver" || exit 1
+ cd "$srcdir/$_pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl