summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon2017-06-14 21:54:20 +0800
committerSimon2017-06-14 21:54:20 +0800
commit75af16ab0487e9e644663cb0d13d20cd38c94b31 (patch)
tree963f882ef58438a1fc917d469bde78da0768f724 /PKGBUILD
downloadaur-python-sphinx-php-git.tar.gz
Initial package push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea24ea8169c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Simon Ball <contact@simonball.me>
+pkgname=('python-sphinx-php-git')
+pkgrel=1
+pkgdesc="Sphinx Extensions for PHP and Symfony"
+url="https://github.com/fabpot/sphinx-php/"
+pkgver=v1.0.10.r1.g7312ecc
+depends=('python')
+makedepends=('git' 'python-setuptools')
+license=('MIT')
+arch=('any')
+source=("git+https://github.com/fabpot/sphinx-php.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/sphinx-php"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package () {
+ cd "${srcdir}/sphinx-php"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}