summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2024-04-28 16:34:48 +0200
committerMartin Diehl2024-04-28 16:34:48 +0200
commite292416edd3bec4705904bbac7524488dfa815c6 (patch)
tree6b1fc8fc036e25c589386d1dcbcbb1533456565b /PKGBUILD
parentece0d28343a5085a8e3b5b688be4936941f6e199 (diff)
downloadaur-python-sphinx-substitution-extensions.tar.gz
2024.02.25
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79252f9bcc8d..496466c138c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Diehl <aur@martin-diehl.net>
pkgname=python-sphinx-substitution-extensions
-pkgver=2022.02.16
+pkgver=2024.02.25
pkgrel=1
pkgdesc='Extensions for Sphinx which allow for substitutions'
arch=('any')
@@ -10,21 +10,15 @@ license=('APACHE')
depends=('python-sphinx')
makedepends=('python-setuptools' 'python-pip')
source=("https://github.com/adamtheturtle/sphinx-substitution-extensions/archive/refs/tags/${pkgver}.tar.gz")
-sha512sums=('202612ad9826ed6e3b02859cf6d7fabf010ad5997a7dd26b47b6383d950514a02bf6738ea2fc0ca47f64bbf66da0c3d83c47cc4b016a2d40112de35b4781fd62')
-
-prepare() {
- cd $srcdir/sphinx-substitution-extensions-${pkgver}
- sed -i 's/use_scm_version=True/use_scm_version=False/g' setup.py
-}
+sha512sums=('678dce24e835f3fdbfce578ca644ffda248334cef3bbea84b9a3ccde78ec6b0bb5ba8ceb145abbf05346bb448bbad729060b314ed8b141f383efed7db7890732')
build() {
- cd $srcdir/sphinx-substitution-extensions-${pkgver}
- python setup.py build_ext --inplace
- python setup.py build
+ cd $srcdir/sphinx-substitution-extensions-${pkgver}
+ python -m build --wheel --no-isolation
}
package() {
- cd $srcdir/sphinx-substitution-extensions-${pkgver}
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd $srcdir/sphinx-substitution-extensions-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}