summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2024-01-17 21:15:14 +0800
committerUniversebenzene2024-01-17 21:15:14 +0800
commitfa75e1a972b3c6a18acbd9b04b82c2e594a254c8 (patch)
tree76b28f0e5b05cdba3d67bbb0be198741d302ddbc /PKGBUILD
parent4e2fc082c789e37f4b04bb2ade7e0c1aff147dac (diff)
downloadaur-python-sphinx-togglebutton.tar.gz
Update to version 0.3.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9529ea536f2a..b22a044df05a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-sphinx-togglebutton
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=1
pkgdesc="Toggle page content and collapse admonitions in Sphinx"
arch=('any')
@@ -13,7 +13,7 @@ makedepends=('python-setuptools')
#checkdepends=('python-sphinx' 'python-wheel')
checkdepends=('python-nose' 'python-docutils')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('cf231636424b4943216c2d3dd77ea2fa')
+md5sums=('bee9c0ef2f3c888085000efcad2d63b7')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -34,8 +34,11 @@ check() {
package_python-sphinx-togglebutton() {
depends=('python-sphinx' 'python-setuptools' 'python-wheel')
optdepends=('python-sphinx-book-theme: sphinx'
- 'python-myst-parser: sphinx'
- 'python-sphinx_design: sphinx')
+ 'python-sphinx-examples: sphinx'
+ 'python-myst-nb: sphinx'
+ 'python-sphinx_design: sphinx'
+ 'python-numpy: sphinx'
+ 'python-matplotlib: sphinx')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"