summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 10:33:04 -0600
committerMark Wagie2022-04-15 10:33:04 -0600
commit56a63c8f1aff1f7d328b64ee9adca0bd5f3b3e95 (patch)
treec5bc42ac4ccd5ee815912baae3566aff773d6933 /PKGBUILD
parentadd9dba9aeed032c3b2f256bbb062dec499b7420 (diff)
downloadaur-python-sphinxcontrib-programoutput.tar.gz
standards based build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4a805faca80..2f6f8c84eb48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,25 @@
pkgname=python-sphinxcontrib-programoutput
_name=${pkgname#python-}
pkgver=0.17
-pkgrel=1
+pkgrel=2
pkgdesc="Sphinx extension to insert the output of arbitrary commands into documents."
arch=('any')
url="https://sphinxcontrib-programoutput.readthedocs.io"
license=('BSD')
depends=('python-sphinx')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
#options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('300ee9b8caee8355d25cc74b4d1c7efd12e608d2ad165e3141d31e6fbc152b7f')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}