summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2022-03-21 20:34:52 +0700
committerAchmad Fathoni2022-03-21 20:34:52 +0700
commitb5e1303132453e063c3e53418bd3dc98be59d622 (patch)
tree41fe056d21f3666c8eea9204a348986e687699e2 /PKGBUILD
parent1c89f44510df04a6b1711ddb785a311d21fa70b3 (diff)
downloadaur-python-sseclient.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df901c271aa1..ea3c449b7fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: Niklas <dev@n1klas.net>
-# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
-
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
pkgname=python-sseclient
+_pkgname=${pkgname:7}
pkgver=0.0.27
pkgrel=1
-pkgdesc="Client library for reading Server Sent Event streams"
+pkgdesc="Python client library for reading Server Sent Event streams."
arch=('any')
-url="https://github.com/btubbs/sseclient"
+url="https://pypi.org/project/${_pkgname}"
license=('MIT')
-depends=('python-requests>=2.0.0' 'python-six')
-makedepends=('python-setuptools' 'git')
-source=("git+${url}.git#tag=v${pkgver}")
-sha512sums=('SKIP')
+makedepends=(python-build python-installer python-wheel)
+depends=(python python-requests python-six)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('b2fe534dcb33b1d3faad13d60c5a7c718e28f85987f2a034ecf5ec279918c11c')
build() {
- cd "$srcdir/sseclient"
- python setup.py build
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/sseclient"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
}