summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVinicius Correa2018-05-31 11:47:26 -0300
committerVinicius Correa2018-05-31 11:47:26 -0300
commitd7aecde20cda230d664fc21122b18ee95f8ccc2b (patch)
tree72ed102e838bd57c113232ccd8a1974280590858 /PKGBUILD
downloadaur-python-stoq-kiwi.tar.gz
first
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6690e154dbed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+_pkgname=kiwi
+pkgname=python-stoq-kiwi
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="A graphical framework to construct simple UI"
+arch=('any')
+url="https://github.com/stoq/${_pkgname}"
+license=('LGPL')
+depends=('python' 'python-setuptools' 'python-zope-interface' 'python-gobject' 'gtk3')
+conflicts=('stoq-server<=0.14.1' 'stoq<=2.2' 'stoqdrivers<=1.3.3' 'kiwi')
+makedepends=('git')
+source=("https://launchpad.net/~stoq-dev/+archive/ubuntu/stoq3/+sourcefiles/${_pkgname}/${pkgver}-2bionic/${_pkgname}_${pkgver}-2bionic.tar.gz")
+md5sums=('b5db443448d3499c292ef42a80e9c2fc')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}