summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCedric Girard2023-05-24 16:25:31 +0200
committerCedric Girard2023-05-24 16:25:31 +0200
commit717171f7340fb1d148f628ddd61e0de9d6d95ba4 (patch)
tree9bf88ca1695b3c90747d4c4a6d83075d893ef963 /PKGBUILD
parent1cf94c0c1006cc390897b0c9b036fb3108000961 (diff)
downloadaur-python-string-utils.tar.gz
upgpkg: python-string-utils 1.0.0-1
adopted and updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70994af0f556..0589ff0ab3da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
-# Maintainer: Giacomo Longo <gabibbo97@gmail.com>
+# Maintainer: Cedric Girard <cgirard [dot] archlinux [at] valinor [dot] fr>
+# Contributor: Giacomo Longo <gabibbo97@gmail.com>
pkgname=python-string-utils
-pkgver=0.6.0
+pkgver=1.0.0
pkgrel=1
-pkgdesc="Utility functions for strings checking and manipulation"
-url="https://github.com/openshift/openshift-restclient-python"
+pkgdesc="Utility functions for strings validation and manipulation"
+url="https://pypi.org/project/python-string-utils/"
license=('APACHE')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
arch=('any')
-makedepends=('python-setuptools')
+makedepends=(python-build python-installer python-wheel python-setuptools)
depends=('python')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('dcf9060b03f07647c0a603408dc8b03f807f3b54a05c6e19eb14460256fac0cb')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py build
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ rm "$pkgdir"/usr/README/README.md
+ rmdir "$pkgdir"/usr/README
}
-md5sums=('76ae6911f4bf0f1e76cd9be749c16745')