summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2024-04-23 11:37:14 +0200
committerJ. Nathanael Philipp2024-04-23 11:37:14 +0200
commitdd151890d8a5e47a0df6d5b562f71242e593f219 (patch)
tree5551d7ad3ab586df142f677ac1e60ee1f7fd2b7e /PKGBUILD
parent105b3ab164945fef25db6f67f3393746642fcbba (diff)
downloadaur-python-thinc.tar.gz
Version 9.0.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67bee918d832..2b5d028bbf07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=python-thinc
_pkg="${pkgname#python-}"
-pkgver=8.2.3
+pkgver=9.0.0
pkgrel=1
pkgdesc='Practical Machine Learning for NLP'
arch=('x86_64' 'aarch64')
@@ -16,7 +16,6 @@ depends=(
'python-catalogue'
'python-confection'
'python-cymem'
- 'python-mock'
'python-murmurhash'
'python-numpy'
'python-packaging'
@@ -25,8 +24,9 @@ depends=(
'python-srsly'
'python-wasabi')
makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+optdepends=('python-cupy' 'python-pytorch' 'python-tensorflow')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/$_pkg/$_pkg-$pkgver.tar.gz")
-sha256sums=('f5afc5222912a80bda8bdcec958362a2ba538d7027dc8db6154845d2859dca76')
+sha256sums=('bbe7fc3dca4f2b89a2c1429e8bf1c9dc20b0faad13f0ac29053bbb3c2531ad57')
build() {
cd "$_pkg-$pkgver"