summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDennis Vestergaard Værum2023-10-28 22:58:16 +0200
committerDennis Vestergaard Værum2023-10-28 22:58:16 +0200
commitda40cf6b77289ff2253ed86d324d156f47939a14 (patch)
tree7b666152fbc2bf39a558d2988d7ea2cead3b7592 /PKGBUILD
downloadaur-python-togglcli.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1e9e92068c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Dennis Værum <archlinux@varum.dk>
+
+_name=toggl-cli
+pkgname="python-togglcli"
+pkgver=2.4.4
+pkgrel=1
+pkgdesc="Command line tool and set of Python wrapper classes for interacting with toggl's API"
+arch=('any')
+url="https://github.com/auhau/toggl-cli"
+license=('MIT')
+groups=()
+depends=(
+ python-pendulum
+ python-requests
+ python-click
+ python-inquirer
+ python-prettytable
+ python-validate-email
+ python-click-completion
+ python-pbr
+ python-notify-py
+)
+makedepends=(python-build python-installer python-wheel twine)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+options=()
+source=("https://github.com/AuHau/${_name}/archive/refs/tags/v${pkgver}.tar.gz")
+noextract=()
+
+sha512sums=('32c28e5f396bb0d084f0ee43f7ca78ac54494b795b23ee41a2d1e7c4c2bf57d794025359620af653ebd35c4f2d02b358d40a4606c41fb9bc2ba76114e2969ce7')
+#sha512sums=("$(curl --location --show-error --silent "${source[0]}" | sha512sum | tr -d '\n -')")
+
+build() {
+ cd "$_name-$pkgver"
+
+ export PBR_VERSION=1.2.3
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}