summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2020-03-06 05:17:48 +0800
committerlilac2020-03-06 05:17:48 +0800
commit0903a9bfd4fc4622789b6a540834fe348bcde40c (patch)
treeb5f49fd887f27e583a5d8a4dd582c9e6b321f3f7 /PKGBUILD
parentc81ac8731ca05798c763d3f7c651a17f8d7d2b58 (diff)
downloadaur-0903a9bfd4fc4622789b6a540834fe348bcde40c.tar.gz
update by lilac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8fd1283e638..00eb2d712acc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=('python-torchvision' 'python-torchvision-cuda')
_pkgname=vision
pkgver=0.5.0
-pkgrel=2
+pkgrel=4
pkgdesc='Datasets, transforms, and models specific to computer vision'
arch=('x86_64')
url='https://github.com/pytorch/vision'
@@ -15,7 +15,6 @@ license=('BSD')
depends=(
'python-numpy'
'python-pillow'
- 'python-pytorch-cuda'
'python-scipy'
'python-six'
'python-tqdm'
@@ -28,6 +27,7 @@ makedepends=(
'cuda'
'ffmpeg'
'python-av'
+ 'python-pytorch-cuda'
'python-setuptools'
'qt5-base'
)
@@ -66,6 +66,8 @@ check() {
}
package_python-torchvision() {
+ depends+=(python-pytorch)
+
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
@@ -73,7 +75,7 @@ package_python-torchvision() {
package_python-torchvision-cuda() {
pkgdesc='Datasets, transforms, and models specific to computer vision (with GPU support)'
- depends+=(cuda)
+ depends+=(python-pytorch-cuda)
provides+=(python-torchvision=${pkgver})
conflicts+=(python-torchvision=${pkgver})