summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2022-05-06 04:46:57 +0800
committerlilac2022-05-06 04:46:57 +0800
commit1665451c21bf032d4f792c539e22bbcb4efdf140 (patch)
tree0bc0e9eb8fabd7364b0bd2c906fcb84dda05c1c9 /PKGBUILD
parent10f95b41c4441015b19206ddb028c20195da030d (diff)
downloadaur-1665451c21bf032d4f792c539e22bbcb4efdf140.tar.gz
[lilac] updated to 0.12.0-7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e323f2e9d08a..44cccfd0993b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _CUDA_ARCH_LIST="5.2;5.3;6.0;6.1;6.2;7.0;7.2;7.5;8.0;8.6;8.6+PTX"
pkgname=('python-torchvision' 'python-torchvision-cuda')
_pkgname=vision
pkgver=0.12.0
-pkgrel=6
+pkgrel=7
pkgdesc='Datasets, transforms, and models specific to computer vision'
arch=('x86_64')
url='https://github.com/pytorch/vision'
@@ -25,7 +25,6 @@ depends=(
python-pillow
python-requests
python-scipy
- python-typing_extensions
)
optdepends=(
'ffmpeg4.4: video reader backend (the recommended one with better performance)'
@@ -77,6 +76,16 @@ build() {
python setup.py build
}
+check() {
+ # check if VideoReader is build
+ # VideoReader depends on ffmpeg
+ PYTHONPATH="${srcdir}/${_pkgname}-${pkgver}/build/lib.linux-${CARCH}-$(get_pyver)" \
+ python -c "from torchvision.io import VideoReader"
+
+ PYTHONPATH="${srcdir}/${_pkgname}-cuda-${pkgver}/build/lib.linux-${CARCH}-$(get_pyver)" \
+ python -c "from torchvision.io import VideoReader"
+}
+
package_python-torchvision() {
depends+=(python-pytorch)