summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Holland2020-12-06 14:47:45 +0100
committerJohannes Holland2020-12-06 14:51:56 +0100
commitcfe4b6e2d816acdb7fe65e68d73ba727e3b26729 (patch)
treea4496d1b8aa088858edc4a8602500148142fdf5b /PKGBUILD
downloadaur-python-tpm2-gui-git.tar.gz
initial commit
Signed-off-by: Johannes Holland <joh.ho@gmx.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..043dd5b28966
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Johannes Holland <joh.ho@gmx.de>
+pkgname=python-tpm2-gui-git
+_name=${pkgname#python-}
+pkgver=0.0.1.r1.2ea1ef7
+pkgrel=1
+pkgdesc='GUI for the TPM Software Stack (TSS) Feature API (FAPI)'
+arch=('any')
+url='https://github.com/joholl/tpm2-gui'
+license=('BSD')
+depends=('python' 'gtk3' 'gobject-introspection-runtime' 'gdk-pixbuf2' 'pango'
+ 'json-c' 'python-tpm2-pytss-git' 'python-gobject'
+ 'python-cryptography')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=('tpm2-gui-git')
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_name%-git}"
+ git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_name%-git}"
+ python setup.py build
+}
+
+check() {
+ cd "${_name%-git}"
+ python -B setup.py test
+}
+
+package() {
+ cd "${_name%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+