summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordigital mystik2023-05-14 15:58:59 -0700
committerdigital mystik2023-05-14 15:58:59 -0700
commit46232257634663283093e5aecd5265b21246a5e4 (patch)
treea59538caf17b2b2d0fcc65af11693215d641f7ad /PKGBUILD
parent69b049012f9acd1b6783d6ff63878bb56963bfb7 (diff)
downloadaur-python-trezor-agent-git.tar.gz
added construct-classes and simple-rlp
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 421553a36e22..3090525f2572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,38 @@
_name=trezor-agent
pkgname=python-trezor-agent-git
-pkgver=v0.14.6.r6.g3044cfe
+pkgver=v0.14.7.r6.gba8a1ba
pkgrel=1
-pkgdesc="Hardware-based SSH/PGP agent (Trezor/Keepkey/Ledger/OnlyKey/Jade)"
+pkgdesc="Hardware-based SSH/PGP agent (Trezor only)"
arch=('any')
url="https://github.com/romanz/trezor-agent"
license=("LGPL3")
provides=('python-trezor-agent')
conflicts=('python-trezor-agent')
+
+# dependencies are for Trezor devices only (other device agents will require their own, some of which are not in the AUR) - please refer to setup.py of each agent for more information
+
depends=(
'python'
- 'python-docutils'
- 'python-wheel'
'python-backports.shutil_which'
- 'python-trezor'
- 'python-configargparse'
+ 'python-bech32'
+ 'python-configargparse'
+ 'python-construct-classes'
+ 'python-cryptography'
'python-daemon'
+ 'python-docutils'
'python-ecdsa'
- 'python-pynacl'
+ 'python-hidapi'
'python-mnemonic'
'python-pymsgbox'
+ 'python-pynacl'
'python-semver'
+ 'python-simple-rlp'
+ 'python-trezor'
'python-unidecode'
- 'python-bech32'
- 'python-hidapi'
- )
+ 'python-wheel'
+ )
+
makedepends=('git' 'python-setuptools')
source=("$pkgname::git+https://github.com/romanz/$_name.git#branch=master")
@@ -41,7 +48,8 @@ build() {
cd "$srcdir/$pkgname"
python setup.py build
- #comment or uncomment for agent selection (don't forget to do the same under the package section)
+ # NOTE: other agents will require their own dependencies, some of which are not in the AUR
+ # comment or uncomment for agent selection (don't forget to do the same under the package section)
cd "$srcdir/$pkgname/agents/trezor"
python setup.py build
@@ -51,9 +59,11 @@ build() {
#cd "$srcdir/$pkgname/agents/ledger"
#python setup.py build
+ ## Note: needs onlykey (PyPi) ##
#cd "$srcdir/$pkgname/agents/onlykey"
#python setup.py build
+ ## NOTE: needs jadepy (PyPi) ##
#cd "$srcdir/$pkgname/agents/jade"
#python setup.py build
}