summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuliette Monsel2023-10-03 14:44:23 +0200
committerJuliette Monsel2023-10-03 14:44:23 +0200
commit52c29a89df694e49883509d4b7bf55c68b03c3ab (patch)
tree49f8e9e4d998241315407a1d31ca9c6049fbc67a /PKGBUILD
parent9387c610c88fd3f88befcc547d4a4d9ae17ea51b (diff)
downloadaur-python-ttkwidgets.tar.gz
New upstream release - v0.13.0
Additionally: - modernize PKGBUILD to follow guidelines - patched ttkwidgets/itemscanvas.py to work with current version of python-pillow
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac4805e5a81e..7067ea53f56a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname=('python-ttkwidgets')
-pkgver=0.12.0
+pkgver=0.13.0
pkgrel=1
pkgdesc="Collection of widgets for Tkinter's ttk extensions"
_name=ttkwidgets
arch=('any')
url="https://github.com/RedFantom/ttkwidgets"
license=('GPL3')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/RedFantom/$_name/archive/${pkgver}.tar.gz")
-sha512sums=('0face6cbb3d40f20c70d848c39c11b460a53a0866536e879c14d5b69d59e18414b54bcad163753481df9bc7ec226308774287b91ee2cdd2826e383b783fc4e93')
-makedepends=('python-setuptools')
+source=("$_name-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha512sums=('085c4e3c2e915e2bdae14731ba0d11f017aa103e60aaceb9e1700311074e609e569ae77d50e76eb598a96aab354a1a62062f8417201f262f34e51d344918f223')
+makedepends=(python-build python-installer python-wheel python-setuptools)
depends=('tk' 'python-pillow')
-checkdepends=(python-pytest)
-build() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
+prepare() {
+ cd "$_name-$pkgver"
+ sed -i "s|ANTIALIAS|LANCZOS|g" ttkwidgets/itemscanvas.py
}
-check() {
- cd "${srcdir}/${_name}-${pkgver}"
- pytest -v
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+
+
+