summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcus Hoffmann2023-01-05 21:58:20 +0100
committerMarcus Hoffmann2023-01-05 21:58:20 +0100
commit101d6afc7415ace3d7faa6399e4d75fc8cb54921 (patch)
treecc6b3dbf4793488e66f1f05faf1fac44f3448686 /PKGBUILD
parent802dc36b5e0500f9b69a34425163591f0ae3a2cc (diff)
downloadaur-python-ua-parser.tar.gz
bump to 0.16.1
switch to python-build/python-installer workflow
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 662eb691c340..c7a08cabf856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
_pkgname=ua-parser
pkgname=python-ua-parser
-pkgver=0.15.0
+pkgver=0.16.1
pkgrel=1
pkgdesc="Python port of Browserscope's user agent parser"
arch=('any')
url="https://pypi.python.org/pypi/ua-parser"
license=('MIT')
+makedepends=(python-build python-installer python-wheel python-setuptools)
depends=('python' 'python-pyaml')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('e441c982ffe81aa7e31af40ac6bf1d39f8ad24f1d34a2d91baae415470b26e9b')
+sha256sums=('ed3efc695f475ffe56248c9789b3016247e9c20e3556cfa4d5aadc78ab4b26c6')
#Tests only run from git resursive checkout
#check() {
@@ -21,10 +22,10 @@ sha256sums=('e441c982ffe81aa7e31af40ac6bf1d39f8ad24f1d34a2d91baae415470b26e9b')
build() {
cd $srcdir/${_pkgname}-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/${_pkgname}-$pkgver"
- python3 setup.py install --root "${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}