summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2024-04-28 19:36:01 +0800
committerlilac2024-04-28 19:36:01 +0800
commite91b9d211e3c2f2215708c75539e71c3d3eec092 (patch)
tree6a1a768198bc44b2dc96cf22e5dbbcd4c8c96760 /PKGBUILD
parentcc43675d5ac8c00f6a7f638655dd70c3da599641 (diff)
downloadaur-python-unet.tar.gz
[lilac] updated to 0.7.9-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1282a766fd9c..5c5d294e0d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-unet
_pkgname=unet
pkgver=0.7.9
-pkgrel=2
+pkgrel=3
pkgdesc='PyTorch Implementation of 2D and 3D U-Net'
arch=(any)
url='https://github.com/fepegar/unet'
@@ -13,7 +13,10 @@ depends=(
)
makedepends=(
numactl
+ python-build
+ python-installer
python-setuptools
+ python-wheel
)
checkdepends=(
python-pytest
@@ -24,7 +27,7 @@ sha512sums=('06bd7da3d661e3a8d85436e3638118d87df3a5b0238977ac4446e61f1b6dfef0c32
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -34,7 +37,7 @@ check() {
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: