summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-23 13:08:38 -0500
committerLuis Martinez2022-03-23 13:08:38 -0500
commit35f2bfe101736486a9d23874e59886127794b148 (patch)
tree229fca83fac63082c3bcfb09e691f2886c368e86 /PKGBUILD
parent3651aff7671a4a74edd69930c8f0f30e7a8dea97 (diff)
downloadaur-python-unp.tar.gz
package cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f66a8aa3ba23..c91be81e0c56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
-# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Thomas Weißschuh <thomas t-8ch de>
pkgname=python-unp
pkgver=0.3
-pkgrel=2
-pkgdesc='Command line tool that can unpack archives easily'
+pkgrel=3
+pkgdesc='Command line tool for unpacking archives'
arch=('any')
url='https://github.com/mitsuhiko/unp'
license=('BSD')
depends=('python-click')
-source=("https://pypi.python.org/packages/source/u/unp/unp-${pkgver}.tar.gz")
-
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
+conflicts=('unp')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/u/unp/unp-$pkgver.tar.gz"
+ 'LICENSE')
+sha256sums=('234807c6db6f802cf25509dd495f7978516f1d04eecd6f0acfef0ac76cba6009'
+ 'ca5da925ab8f92d6902170575b9298db099d92060a12af203d409b8d41145a6e')
build() {
- cd "${srcdir}/unp-${pkgver}"
- python setup.py build
+ cd "unp-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/unp-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ export PYTHONHASHSEED=0
+ cd "unp-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README -t "$pkgdir/usr/share/doc/$pkgname/"
}
-
-sha256sums=('234807c6db6f802cf25509dd495f7978516f1d04eecd6f0acfef0ac76cba6009')