summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-31 12:16:38 -0500
committerLuis Martinez2022-03-31 12:16:38 -0500
commit4ccf0694e7eb5aeedd3b980ac9e63bd76549dbd3 (patch)
tree429cfd9cee54fd7fc35e84ed0e61e99ccf63fafe /PKGBUILD
parent8b4f2a3a8e44cf5bd90fa1e0cf3990946e796626 (diff)
downloadaur-python-webruntime.tar.gz
packaging update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07242026550f..cf6a52dd7b92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,31 @@
pkgname=python-webruntime
pkgver=0.5.8
-pkgrel=3
+pkgrel=4
pkgdesc='Launch HTML5 apps in the browser or a desktop-like runtime.'
arch=('any')
url='https://github.com/flexxui/webruntime'
license=('BSD')
depends=('python-dialite')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('08e4ea844e544b28433c35bd485cecaa672d60b5206877f7b4bb49d537fd248c')
build() {
cd "webruntime-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
+ export PYTHONHASHSEED=0
cd "webruntime-$pkgver"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/webruntime-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}
# vim: ts=2 sw=2 et: