summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornlufr2016-01-30 12:12:18 +0100
committernlufr2016-01-30 12:12:18 +0100
commit9752a52eec4b2cf4bf9f087789bb7af461331d1d (patch)
treea4cfa253fc3668ea60786d02f4333f03319313b6 /PKGBUILD
downloadaur-python-whatportis.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..feeab0af4aaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: philou <philou at mailz dot org>
+
+pkgname=python-whatportis
+pkgver=0.4
+pkgrel=1
+pkgdesc="A Python command to search port names and numbers"
+arch=('any')
+makedepends=('python-setuptools')
+url="https://github.com/ncrocfer/whatportis"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/w/${pkgname#python-}/${pkgname#python-}-$pkgver.tar.gz)
+md5sums=('cf825d8289f367936f2dfb8682b39bdf')
+
+build() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ msg 'Building...'
+ python setup.py build
+}
+
+package() {
+ depends=('python-click>=6.2' 'python-prettytable>=0.7.2')
+
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ msg 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}