summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A.2025-01-11 18:12:21 +0100
committerGitHub2025-01-11 18:12:21 +0100
commiteb0f9466101a2fbc333e8c907b88e0b14c26e4cb (patch)
tree06189bd9ff1842c652cc3b91afbd79adc99692e0 /PKGBUILD
parentcea455f18982fea0c5f4a419c74e07b9f094cf18 (diff)
downloadaur-python-wheel-filename.tar.gz
Update package python-wheel-filename from 1.4.1 to 1.4.2 (#79)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 589c5a9c7620..9c089ec44180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
_name=wheel-filename
pkgname=python-$_name
-pkgver=1.4.1
-pkgrel=2
+pkgver=1.4.2
+pkgrel=1
pkgdesc='Parse wheel filenames'
arch=(any)
url="https://github.com/jwodder/$_name"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools python-build python-installer python-wheel)
+makedepends=(python-hatchling python-build python-installer)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/${_name/-/_}-$pkgver.tar.gz")
sha256sums=('87891c465dcbb40b40394a906f01a93214bdd51aa5d25e3a9a59cae62bc298fd')
build() {
- cd "$_name-$pkgver"
+ cd "${_name/-/_}-$pkgver"
python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
+ cd "${_name/-/_}-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
}