summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBet42020-12-18 19:44:01 +0800
committerBet42020-12-18 19:44:01 +0800
commit8278de40a88a12769c01cb9df6c17b66629cb8c1 (patch)
tree631c92b888fdce8fdfd148f38dbfd3d863c8b8b8 /PKGBUILD
downloadaur-python-whirlpool.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdff21f51e22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Bet4 <bet4it@gmail.com>
+
+_pkgname=Whirlpool
+pkgname=python-whirlpool
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Python wrapper extension for C Whirlpool digest reference implementation"
+arch=('x86_64')
+url="https://github.com/oohlaf/python-whirlpool"
+license=('Unlicense')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('b8e60a8f5a0e09ad0c4015c2f7911d34afedd9dc18528a3c6197475e94b96f54')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}