summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSerge Victor2015-10-03 11:29:44 +0700
committerSerge Victor2015-10-03 11:29:44 +0700
commit3f6685e71810986d63f929a53eb89d33512237e4 (patch)
treec10379cd6b2522226a0293ea18e90000710d9c9d /PKGBUILD
downloadaur-python-wikitools.tar.gz
New to arch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce8178268471
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Serge Victor <arch@random.re>
+#
+# This PKGBUILD includes commented out future-proof version for python3,
+# which is currently not supported by the package, unfortunately
+
+_pipname=wikitools
+pkgbase=python-wikitools
+#pkgname=('python2-wikitools' 'python-wikitools')
+pkgname=('python2-wikitools')
+pkgver=1.3
+pkgrel=1
+pkgdesc="Python package for interacting with a MediaWiki wiki"
+arch=('any')
+url="https://github.com/alexz-enwp/wikitools"
+license=('GPL3')
+#makedepends=('python2-setuptools' 'python-setuptools')
+makedepends=('python2-setuptools')
+source=("https://pypi.python.org/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz")
+md5sums=('50ffe54dd1903cbd52538012b41bf481')
+
+
+prepare() {
+ cp -R $_pipname-$pkgver python2-$_pipname-$pkgver
+}
+
+package_python2-wikitools() {
+depends=('python2')
+
+ cd python2-$_pipname-$pkgver
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+}
+
+#package_python-wikitools() {
+#depends=('python')
+#
+# cd $_pipname-$pkgver
+# python setup.py install --root="$pkgdir/" --optimize=1#
+#
+#}
+