summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 18:14:32 +0100
committerBartłomiej Piotrowski2018-01-07 18:14:32 +0100
commit0d6fd35873964556f1817cffcaca1e2c8badbf88 (patch)
tree2b64dc46b5d554ebececbd774b52cb380f008c4e /PKGBUILD
downloadaur-python-wpactrl.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d057a5d8d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 310007 2017-11-15 14:11:34Z foutrelis $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+
+pkgbase=python-wpactrl
+pkgname=python2-wpactrl
+pkgver=20090609
+pkgrel=6
+pkgdesc="A Python extension for wpa_supplicant/hostapd control interface access"
+arch=('x86_64')
+url="http://projects.otaku42.de/wiki/PythonWpaCtrl"
+license=('GPL2')
+depends=('python2')
+conflicts=('python-wpactrl<=20090609-3')
+replaces=('python-wpactrl<=20090609-3')
+source=(https://sources.archlinux.org/other/${pkgbase}/python-wpactrl-20090609.tar.gz)
+md5sums=('8d45739aa9bfa1110a4570bb5ceda768')
+
+build() {
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python2 setup.py build
+}
+
+package_python2-wpactrl() {
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}"
+}