summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPuqns672024-02-08 16:18:36 +0800
committerPuqns672024-02-08 16:18:36 +0800
commit11770941efd9a264a965c81d763603f73a9f0698 (patch)
tree083c5a53ce325614ef14d195e55765bc1a302e17 /PKGBUILD
parent67a8636537009a1b77a861de523465a0d68f677b (diff)
downloadaur-python-xmldiff.tar.gz
update 2.6.3-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2ba0a687c89..08b3fbfb0174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,34 @@
-# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: Puqns67 <me@puqns67.icu>
+# Contributor: Guillaume Horel <guillaume.horel@gmail.com>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
-pkgname=python-xmldiff
-_pyname=${pkgname#python-}
+_name='xmldiff'
+pkgname="python-${_name}"
pkgver=2.6.3
-pkgrel=1
+pkgrel=2
pkgdesc='A libray and command line utility for diffing xml'
-arch=(any)
-url="https://$_pyname.readthedocs.io"
-license=(BSD)
-depends=(python
- python-lxml
- python-six)
-makedepends=(python-{build,installer,wheel}
- python-setuptools)
-_archive="$_pyname-$pkgver"
-source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
-sha256sums=('19b030b3fa37d1f0b5c5ad9ada9059884c3bf2c751c5dd8f1eb4ed49cfe3fc60')
+url="https://github.com/Shoobx/xmldiff"
+license=('MIT')
+arch=('any')
+depends=('python' 'python-lxml' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+
+source=("${_name}-${pkgver}.tar.gz"::"${url}/archive/refs/tags/${pkgver}.tar.gz")
+
+b2sums=('7fc6e19bae7904301cfa5048d4fa7ad757bab000c50975acf8261107b8224558abfdf9d95935404c26e09cf616bacbc4f3deefd7a9e600ff0ec9d22100ba64b1')
build() {
- cd "$_archive"
- python -m build -wn
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
}
check() {
- cd "$_archive"
- python -m unittest discover
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m unittest
}
package() {
- cd "$_archive"
- python -m installer -d "$pkgdir" dist/*.whl
- install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 "${srcdir}/${_name}-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}