summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-02-19 10:49:39 -0600
committerLuis Martinez2022-02-19 10:49:39 -0600
commit547eda797af11637556a36179c5c60422b18cb9c (patch)
treef170339394f961039c6161de4cda44b4f8779a8c /PKGBUILD
parent53b65b62bfe775ea3a824701cba57ad339abcf19 (diff)
downloadaur-python-yeelight.tar.gz
update to 0.7.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca14d32167f7..a851a9e5bea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,22 @@
# Contributor: tsipizic
pkgname=python-yeelight
-pkgver=0.7.8
-pkgrel=2
-_commit=40c09bd4
+pkgver=0.7.9
+pkgrel=1
+_commit=8ecef2f8
pkgdesc='Python library for controlling YeeLight RGB bulbs'
arch=('any')
url='https://gitlab.com/stavros/python-yeelight'
license=('BSD')
depends=('python-future' 'python-ifaddr')
-makedepends=('git' 'python-setuptools' 'python-sphinx' 'python-sphinx_rtd_theme')
+makedepends=(
+ 'git'
+ 'python-flit-core'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-sphinx'
+ 'python-sphinx_rtd_theme')
changelog=CHANGELOG.md
source=("$pkgname::git+$url#commit=$_commit?signed")
sha256sums=('SKIP')
@@ -19,14 +26,15 @@ validpgpkeys=('3D2E921F15667F0FD5B3017E26EA345ECD4C2A63')
build() {
cd "$pkgname"
- python setup.py build
+ PYTHONPATH=./ python -m build --wheel --skip-dependency-check --no-isolation
cd docs
PYTHONPATH=../ make man
}
package() {
+ export PTYHONHASHSEED=0
cd "$pkgname"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm644 docs/build/man/yeelight.1 -t "$pkgdir/usr/share/man/man1/"