summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2021-06-11 20:12:15 +0200
committerPopolon2021-06-11 20:12:15 +0200
commite8ec5cb17a011eb05db5f063645657ea65e79300 (patch)
tree262088c38319247f0f81151c0424d0bfeb6a2086 /PKGBUILD
downloadaur-python-zopflipy.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccf63dba2d3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Popolon <popolon@popolon.org>
+
+pkgbase='python-zopflipy'
+pkgname=('python-zopflipy')
+_module='zopflipy'
+pkgver='1.5'
+pkgrel=1
+pkgdesc="A Python bindings for Zopfli"
+url="https://github.com/hattya/zopflipy"
+depends=('python')
+makedepends=('python-setuptools')
+license=('APACHE')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/fc/63/5c088c11bc21950ca888f8c1ef0170e4a4670b68e8d107d49d32e8de7549/zopflipy-${pkgver}.zip")
+sha256sums=('7f12ced241a403f588994a77fc7ae1c5e76fb2a965ac1d3bdf444e2a2c7e113d')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}