summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnty02022-04-06 01:29:21 +0200
committerAnty02022-04-06 01:29:21 +0200
commit8270c8a2736aa28bb35335a58b327fe395f41b04 (patch)
tree18f2b0a021951865501eb0932a543efb4c12c08d /PKGBUILD
parentaa801d51dfa453eccbfa0ced4d35ec3e91d7266a (diff)
downloadaur-python-zulip-term-git.tar.gz
update source url; add check to run tests;
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd82b2778aca..34eaa876f755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='python-zulip-term-git'
_pkgname='zulip-terminal'
-pkgver=0.6.0.r468.09a824d2cf
+pkgver=0.6.0.r539.a9d354c608
pkgrel=1
pkgdesc="An interactive terminal interface for Zulip"
arch=('any')
@@ -21,9 +21,10 @@ depends=('python'
'python-pytz'
'python-pyperclip')
makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-pytest-mock' 'python-pytest-cov')
provides=('python-zulip-term')
conflicts=('python-zulip-term')
-source=('git://github.com/zulip/zulip-terminal#branch=main')
+source=('git+https://github.com/zulip/zulip-terminal#branch=main')
sha512sums=('SKIP')
pkgver() {
@@ -37,10 +38,14 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
- touch ./zulipterminal/themes/__init__.py # create missing init file of zulipterminal.themes module
python setup.py build
}
+check(){
+ cd "$srcdir/$_pkgname"
+ pytest
+}
+
package() {
cd "$srcdir/$_pkgname"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1