summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEkin Dursun2019-07-18 23:20:56 +0300
committerEkin Dursun2019-07-18 23:20:56 +0300
commitf8a3861428b9dd781043c239f4290fa84badd855 (patch)
tree533d1a69c3f84bca6d67f508a0796f33311a5a5f /PKGBUILD
downloadaur-python2-astral.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abbcad290655
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Ekin Dursun <ekindursun@gmail.com>
+# Contributor: Gregoire Seux <grego_aur@familleseux.net>
+
+pkgname=python2-astral
+_name='astral'
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="Calculations for the position of the sun and moon."
+url="https://github.com/sffjunkie/astral"
+depends=('python2-pytz')
+optdepends=('python2-requests: for Google geocoding support')
+makedepends=('python2-setuptools')
+license=('Apache')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('d2a67243c4503131c856cafb1b1276de52a86e5b8a1d507b7e08bee51cb67bf1')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}