summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2018-12-08 16:34:00 +0800
committerUniversebenzene2018-12-08 16:34:00 +0800
commit3b65069de40bfc568d7da41500449fb0fe559c52 (patch)
treeb74bb3c44976351804de70695f596314ffe2d13d /PKGBUILD
parent25cb98428ee394cef358b81ec3aae0cb6ab4e5aa (diff)
downloadaur-python2-astroscrappy.tar.gz
Update for astropy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 036dcbf43275..a6050aef631e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,11 @@ arch=('i686' 'x86_64')
url="https://github.com/astropy/astroscrappy"
license=('BSD')
depends=('python2' 'python2-numpy' 'python2-astropy' 'cython2>=0.21')
-optdepends=('python-astroscrappy-doc: Documentation for Astro-SCRAPPY')
+optdepends=('python-astroscrappy-doc: Documentation for Astro-SCRAPPY'
+ 'python2-pytest<3.7: For testing'
+ 'python2-scipy: For testing')
makedepends=('python2-astropy-helpers')
-checkdepends=('python2-pytest' 'python2-scipy')
+#checkdepends=('python2-pytest' 'python2-scipy')
source=("https://files.pythonhosted.org/packages/source/a/astroscrappy/astroscrappy-${pkgver}.tar.gz")
md5sums=('e7ec5d829191226e6092b08e1d8f4cd4')
@@ -18,15 +20,15 @@ prepare() {
sed -i -e '/auto_use/s/True/False/' setup.cfg
}
-build () {
+build() {
cd ${srcdir}/astroscrappy-${pkgver}
python2 setup.py build --use-system-libraries --offline
}
-check(){
- cd $srcdir/astroscrappy-${pkgver}
- python2 setup.py test
-}
+#check() {
+# cd ${srcdir}/astroscrappy-${pkgver}
+# python2 setup.py test
+#}
package() {
cd ${srcdir}/astroscrappy-${pkgver}