summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-06-10 01:06:59 +0300
committerErhan SAHIN2015-06-10 01:06:59 +0300
commit5fac50b6ea1d53a1e056086b2b3316cab3c93492 (patch)
treebeb1201c42628dea5cfa647073d179be23f1aaf8 /PKGBUILD
downloadaur-python2-barbicanclient-kilo.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0f44fd6ab0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Erhan SAHIN < erhan@ssahin.net >
+
+pkgname=("python2-barbicanclient-kilo")
+pkgver="3.0.3"
+pkgrel="2"
+pkgdesc="Python client library for Barbican"
+arch=("any")
+url="https://launchpad.net/python-barbicanclient"
+license=("Apache")
+depends=("python2-pbr>=0.6"
+ "python2-argparse"
+ "python2-prettytable>=0.7"
+ "python2-requests>=2.2.0"
+ "python2-six>=1.7.0"
+ "python2-keystoneclient-kilo"
+ "python2-cliff-kilo"
+ "python2-oslo-i18n-kilo"
+ "python2-oslo-serialization-kilo"
+ "python2-oslo-utils-kilo")
+makedepends=("python2-setuptools")
+source=("https://pypi.python.org/packages/source/p/python-barbicanclient/python-barbicanclient-${pkgver}.tar.gz")
+sha256sums=('959aca2ce3af2eed0f57e2fa9f0f9a484e40adc6b371e2c0fcc588aae9ca2b18')
+
+package() {
+ cd "${srcdir}/python-barbicanclient-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}