summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErhan SAHIN2015-06-10 01:11:19 +0300
committerErhan SAHIN2015-06-10 01:11:19 +0300
commite83db63bf46c28e0b9cdced2d032560a6850b903 (patch)
tree37b2d7a85610ce276ade2d1d48b7b933f32275ca /PKGBUILD
downloadaur-python2-cliff-kilo.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e6e9c112a83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=("python2-cliff-kilo")
+pkgver="1.10.1"
+pkgrel="1"
+pkgdesc="Command Line Interface Formulation Framework"
+arch=("any")
+url="https://github.com/openstack/cliff"
+license=("Apache")
+makedepends=("python2-setuptools")
+source=("https://pypi.python.org/packages/source/c/cliff/cliff-${pkgver}.tar.gz")
+sha256sums=('ddfec39bf0de7b53666045c946d495ca070e538e5f92dc19588596c9bcc52c6e')
+
+package() {
+ depends=("python2-cmd2>=0.6.7"
+ "python2-prettytable>=0.7"
+ "python2-pyparsing>=2.0.1"
+ "python2-six>=1.9.0"
+ "python2-stevedore-kilo")
+ cd "${srcdir}/cliff-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}