summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorenz Steinert2019-12-01 19:18:04 +0100
committerLorenz Steinert2019-12-01 19:18:04 +0100
commit31798cdcd7ad8faf862eaccd5c9297e6dcd5d1c3 (patch)
tree13effca860d57bdb5332147acc228a823e02ae65 /PKGBUILD
downloadaur-python2-django-appconf.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3078d6aa7168
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('python2-django-appconf')
+_pkgbase='django-appconf'
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A helper class for handling configuration defaults of packaged Django apps gracefully"
+arch=(any)
+url="https://github.com/django-compressor/django-appconf"
+license=('BSD')
+options=(!emptydirs)
+source=("$_pkgbase-$pkgver.tar.gz::https://github.com/django-compressor/django-appconf/archive/v${pkgver}.tar.gz")
+sha256sums=('7ed2a219b0195d13c7f7e82d77710c3a3478c997049a3749aaf16a319a084933')
+makedepends=('python2-setuptools')
+
+package_python2-django-appconf() {
+ depends=('python2-django' 'python2-six')
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: