summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormutantmonkey2014-10-10 19:29:30 -0700
committermutantmonkey2014-10-10 19:29:30 -0700
commitddd43726f5f98802ea800b26e701affdfd44ae53 (patch)
tree5b5d337519d827066f6be0e650ecda8f0e8b4bef /PKGBUILD
parent7dfdc679e2a98220c6e3bbf85ac5a16aecd0910d (diff)
downloadaur-python2-fte.tar.gz
upgrade python2-fte and fteproxy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5140ac09484..cea726043155 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mutantmonkey <aur@mutantmonkey.in>
pkgname=python2-fte
-pkgver=0.0.4
-pkgrel=2
+pkgver=0.1.0
+pkgrel=1
pkgdesc="Implementation of Format-Transforming Encryption (FTE)"
arch=('i686' 'x86_64')
url="https://github.com/kpdyer/libfte"
@@ -9,18 +9,18 @@ license=('GPL')
depends=('python2' 'gmp>=5.1')
makedepends=('python2-setuptools')
source=("https://pypi.python.org/packages/source/f/fte/fte-${pkgver}.tar.gz")
-sha256sums=('0803946562e07693f43954943c4902c92504e2440afe30f9f68f374a1f4bef91')
-
-prepare() {
- cd "$srcdir/fte-$pkgver"
- sed -i 's/PYTHON="python"/PYTHON="python2"/' Makefile
-}
+sha256sums=('6c4900b2ce4554d6101665a446ca5bd2ca84bb6786913a855edcedb1b142e740')
build() {
cd "$srcdir/fte-$pkgver"
- CXXFLAGS="${CXXFLAGS} -fPIC" make
+ python2 setup.py build
}
+#check() {
+# cd "$srcdir/fte-$pkgver"
+# python2 setup.py test
+#}
+
package() {
cd "$srcdir/fte-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1