summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Danier2015-07-11 11:58:09 +0200
committerDavid Danier2015-07-11 11:58:09 +0200
commitb80c4ee6e9e327fc02c594a769b9d66632c75380 (patch)
tree7c3989c544d87e3d34f4920c33a41a49813fa9c3 /PKGBUILD
downloadaur-python2-gitifyhg.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e6c76dbc46f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: David Danier <david.danier@team23.de>
+pkgname=python2-gitifyhg
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="git remote that allows local development and push changes to upstream mercurial"
+arch=('any')
+url="https://pypi.python.org/pypi/gitifyhg/"
+license=('GPL3')
+groups=()
+depends=('python2' 'python2-path' 'mercurial')
+makedepends=('python2-distribute')
+optdepends=('git: clone hg repos')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(http://pypi.python.org/packages/source/g/gitifyhg/gitifyhg-$pkgver.tar.gz)
+md5sums=('f8580e1358c794793cf223157fbcec61')
+
+package() {
+ cd "$srcdir/gitifyhg-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ # Remove "path.py" dep as this does not work with python2-path
+ echo "Mercurial" > $pkgdir/./usr/lib/python*/site-packages/gitifyhg-$pkgver-py*.egg-info/requires.txt
+}
+
+# vim:set ts=2 sw=2 et: