summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard PALO2018-02-11 17:10:08 +0100
committerRichard PALO2018-02-11 17:10:08 +0100
commit78d2311bab03f82e875fda0f1e140e1deb1f2788 (patch)
treef5705ab53fac97964e22f98d1fe9e6c6161cd9fc /PKGBUILD
downloadaur-python2-hgnested.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f4e233be56c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Richard PALO <richard.palo@free.fr>
+pkgname=python2-hgnested
+pkgver=0.8
+pkgrel=1
+pkgdesc="Mercurial extension to work with nested repositories"
+arch=('any')
+url="http://bitbucket.org/cedk/hgnested"
+license=('GPL3')
+depends=('python2' 'mercurial')
+optdepends=()
+makedepends=('python2')
+md5sums=('39be601066db908b6fd1d4e19f98e0e3')
+source=("https://pypi.io/packages/source/h/hgnested/hgnested-$pkgver.tar.gz")
+
+build() {
+ cd $srcdir/hgnested-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/hgnested-$pkgver
+ python2 setup.py install --root=$pkgdir
+}