summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Aclander2019-04-12 21:08:49 -0700
committerNathan Aclander2019-04-12 21:08:49 -0700
commiteb0041ab20468f2b76c8deaece7e9ef7552c9a66 (patch)
tree3a8b7586819d60eca7781257aba8c5287a0dbb91 /PKGBUILD
downloadaur-python2-inputscope.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ccc4ae5233e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nathan Aclander < nathan dot aclander at gmail >
+
+_name="inputscope"
+pkgname="python2-$_name"
+url="https://github.com/suurjaak/InputScope"
+pkgver=1.1
+pkgrel=1
+pkgdesc="Mouse and keyboard input heatmap visualizer and statistics."
+arch=("any")
+url="https://github.com/suurjaak/$_name"
+license=("MIT")
+makedepends=("python2-setuptools")
+depends=("python2-bottle" "python2-pyuserinput-git>=86.9fd2879-1")
+source=("https://github.com/suurjaak/InputScope/archive/v$pkgver.tar.gz")
+sha256sums=('80fcd548d66012703d8996782c625f20d1fd39b91266dba16a4fdd52a11120e9')
+
+build() {
+ cd InputScope-$pkgver/
+ python2 setup.py build
+}
+
+package() {
+ cd InputScope-$pkgver/
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+}